
0.7.6 13 May 2010
* Added external preview option by letting the user check the box "external 
preview" and choose a size. ImageFuser will use the Preview.app for this.
Changes in size and settings will become active when loading a new image 
set.
Note that the state of the checkbox is an "auto-saved" setting and will be 
remembered between sessions, the image size is not. 
Note also that if you select a size bigger than your screen size, Preview will 
automatically size the image to your screen meaning that you have to use the 
zoom buttons.

0.7.5 04 May 2010
* Option to create an enfused image and a HDR image in one go.
* Bugfix: Overwrite check of HDR image wasn't handled correctly.
* Bugfix: Progress bar in enfuse only run disabled by accident. Now enabled 
again.
* Minor changes to screen layout due to string lengths in different languages.
* Updated the manual. Added a chapter about increased depth of field by 
using the technique of focus stacking.
* Added functionality for dealing with Tiffs with previews inside.
Some (DSLR) cameras like Canons and Nikons and some programs do make a 
small preview inside the 16bit tiff image. If you open such a 16bit tiff image in 
Apple's Preview you will actually see two images. The original "big" one and a 
small fast preview one for applications that do recognise such a tiff image.
Also when converting from raw to tiff, some "camera delivered" conversion 
programs also create these 16bit multilayer-tiffs: the normal large tiff with alpha-
mask and the small preview image. So, the resulting tiff contains a "normal" image 
with an alpha-mask, and a thumbnail without an alpha mask. Enfuse can deal with 
multilayer tiffs. It will even compensate for differences in size (e.g. the thumbnail). 
However, it can't work with tiffs internally having tiffs with and without an alpha-
mask. That's why enfuse will crash on these images.

Align_image_stack isn't that smart. It finds a tiff, grabs the first image out of it (the 
big one), and continues with the second tiff file in the bracketed set, doing the 
same. It then creates intermediate tiffs which, off course, only contain one image, 
either with or without alpha-mask, depending whether the original first image in the 
multi-layer tiff contained an alpha-mask.
Enfuse fuses these intermediate tiffs from AIS without problems.

I already talked this over with the enfuse developers and they absolutely do not 
consider this a bug. It's a tiff option, for a good reason, but one that doesn't work 
nicely with enfuse.

This "phenomenon" can also occur with 8bit tiffs having a normal image and a 
preview image. In my experience untill now the "large" normal tiffs in these 8bit 
multi-layer tiffs do not contain an alpha-mask. This means that enfuse will fuse them 
nicely. The resulting image however is a fused image with in the top-left corner a 



fused "mini" image from the previews.

In good "Mac fashion" ImageFuser handles this now automatically by converting 
any tiff to an intermediate tiff in an enfuse run without align_image_stack being 
selected, as that's the situation that can lead to errors. 
 

0.7.4.5 12 February 2010
* Bugfix: Inconsistent use of Escape characters made ExifTool fail in one 
case and not in another.
* Clarify use of OK and Save in Preferences screen.
* Switched naming option 1 and 2 in batch screen. Multiple user requests.

0.7.4.4 12 January 2010
* Complete German translation by Thorsten Schumm (Thank you). 

0.7.4.3 03 January 2010
* Bugfixes: debug message not removed. "Use main screen 
Align_image_stack settings" not correctly implemented.
* All checkboxes on Batch screen are now remembered between program 
sessions.
* Checkboxes on Align_Image_Stack screen are now remembered between 
program sessions (apart from autoHFOV which is always on by default).

0.7.4.2 31 December 2009
* Bugfix: cascade of bugs in exif functions. Should now be correct for all.
* Batch screen: Added a checkbox "Use main screen Align_image_stack 
settings". Works only when "Align images"  has been set.

0.7.4.1 29 December 2009
* Bugfix: Writing filedate based on exif-date did not function anymore. This 
due to spaces bugfix in 0.7.2.3. Here it was double-escaped which confused 
Applescript.

0.7.4 22 December 2009
* Added Preferences pane. Defined a "preferred start directory (for source 
images), a preferred "Save to" directory and a "debug" option. The last will 
write log entries to the system log. You can retrieve that info with a button.
* Checkbox settings of "Use align_image_stack", "Set image date to exif 
date"  (both main screen and batch screen) and "Show image after enfuse" 
are remembered between program sessions. Note: this has no relation to 
Preferences.



* (The final) Enfuse 4.0 is now used. 
* Align_Image_stack is updated to the "December version" of the Hugin trunk.

Note: This version is not tested on Tiger. End June my macbook crashed. I had a 
dual-boot system to work in Leopard and Tiger. After 6 weeks without mac I got 
myself another one. But I don't have Tiger anymore. Issues in the past that 
sometimes occurred when built on Leopard was the fact that the openening images 
didn't work, but you could still drop files onto the table.I'm looking for a solution but 
it's not on my priorities list.

0.7.2.3 14 October 2009
* Bugfix: loading of images to table often makes the system hang on 10.6. 
This sometimes happen also on 10.5. It is an undocumented Apple bug in the 
table function. This has now been corrected.
* Bugfix: Final exiftool step didn't handle spaces in paths and images 
correctly.
* Bugfix: enfuse had a bug that it didn't handle the Saturation option correctly. 
That has been fixed.

Note: This version is not tested on Tiger. End June my macbook crashed. I had a 
dual-boot system to work in Leopard and Tiger. After 6 weeks without mac I got 
myself another one. But I don't have Tiger anymore. Issues in the past that 
sometimes occurred when built on Leopard was the fact that the openening images 
didn't work, but you could still drop files onto the table.I'm looking for a solution but 
it's not on my priorities list.

0.7.2.2 26 June 2009
* Fixed bug in 16 bit tiffs. They were not loaded

0.7.2.1 21 June 2009
* Minor bugfix: forgot to change (and test) the "align preview" code after 
change from "Save as:" options.

0.7.2 20 June 2009
* set CIECAM02 option default back(!) to off. In 0.6 it was set to On (by 
default) as enfuse automatically uses it when a profile is available. However, 
it makes enfuse 4-6 times slower, also for non-CIECAM02 images! Now the 
speed is back.
* Use align_image_stack checkbox set from default ON to default OFF (both 
main screen and batch screen)
* Added option "Show image / Don't show image" after enfuse run.
* Bugfix: when converting from png/tiff with alpha-channel to jpg, the new 
enfuse made ImageFuser "stumble" on this conversion.
* Changed bulky "Save as:" radio button matrix to slim dropdown.
* Option "Show source image"  from table.



0.7.1 15 June 2009
* Added option to set fused image file date to exif date (in order of 
CreateDate, DateTimeOriginal, modifyDate). Sometimes your "shooting" date 
is days or weeks earlier than your "fusing" date. iPhoto orders and shows 
images by file date. When you like to keep your source and enfused images 
together, it can be handy to "time stamp" the fused image date to the image's 
exif date. When no exif dates available you will see a warning (batch mode 
will not display a warning).

0.7.0.1 13 June 2009
* Only fixed bug in loading of jpegs (real bug) and loading of Raw images. 
With some raw images the internal timing of Applescript is not correct. I had 
to build in a 1 second delay on loading the images for display in the table. I 
hope this works for everybody.

0.7 6 June 2009
* Added Raw Image support. Every raw image as supported by OSX can be 
opened. As Enfuse and Align_Image_Stack can't handle RAW formats, the 
images are pre-converted to 16bit TIFF.
- For Leopard compatibility see (http://support.apple.com/kb/HT1475)
- For Tiger with iPhoto 5 see (http://support.apple.com/kb/TA22898)
- For Tiger with iPhoto 6 see (http://support.apple.com/kb/TA24044)
See (Menu) Help->Online manual; Appendix A
* Added localization. ImageFuser is now setup for English, Dutch, German, 
French and Italian with some basic translations. Any language can be added.
Volunteers wanted for translation!
See (Menu) Help->Online manual; Appendix B
* Minor bugfix in path statements for bulk process
* Changed from static standalone binaries to dynamically compiled binaries.
* Minor cosmetic changes to allow for localization: english is a compact 
language.
* On quit all temporary images are removed. After every batch run the 
temporary images are removed.

known bugs: Align_Image_Stack can't create proper hdr's from tiff input. In 
case you have RAW images (which are preconverted to TIFF) or 8/16/32 bit 
TIFF images, you need to preconvert them to 8/16/32 png or jpg.

0.6.5.1 16 April 2009
* Fix for dragging images onto image pane. This made ImageFuser hang or it 
functioned dead slow.



Reason: I changed behaviour of batch screen, that influenced dragging of 
images. The batch screen continuously jumped to the foreground and stayed 
tgere. That's designed behaviour of Applescript but really annoying for batch 
behaviour. Now it swaps to the foreground and than I manually switch the 
previous foreground application imediately back to the foreground. I didn't 
mention that in the Changelog as I still don't think it's OK, it's only improved.

0.6.5 14 April 2009
* Added checkbox "Instant Preview" (default On). On every action the 
preview is updated. Sometimes you want to make 3 or 4 (or more) quick 
settings before fine-tuning. In that case you don't want to wait for every 
setting to update.
* Added checkbox "Use main screen enfuse (expert) settings" (default Off) in 
the Batch screen. When switched on this will enable you to use your preset 
enfuse (expert) options from the main screen on the total batch.
* More options for naming the resulting images in batch mode from 3 to 7.
* Added chapter about noise reduction with with ImageFuser/Enfuse to online 
manual (via "Help" -> "ImageFuser Online Manual")

0.6 4 April 2009
* Added the "Enfuse Expert options"  to ImageFuser (It took me weeks to 
discover that enfuse contained bugs whereas I thought it was in my 
programming). 
* Christoph Spiel created a bugfix to enable the use of the "Enfuse Expert 
Options" on OSX as the string conversion contained a bug.
* Christoph Spiel optimized the "channel widening" (going to and from 8bit to 
16bit or 32bit) in enfuse. His version can be downloaded via https://
code.launchpad.net/~cspiel/enblend/staging, which is a branch of the original 
enblend/enfuse trunk.
* enfuse upgraded to ~cspiel/enblend/staging branch 285.
* Bugfix: stupid little bug w.r.t. "What's new" popup.
* Bugfix for "Image Info": It now handles spaces in image names and image 
paths correctly.
* Set CIECAM02 option default to on. When user images contain a non RGB 
profile, the user definitely wants to use it. Also with ciecam02 switched on, 
Enfuse detects if the image does or does not contain ECC profiles and 
automatically switches to default RGB colorspace when relevant.
* Added support for 8bit and 16bit PNG, both input and output (and in batch)
* Output format can be selected from batch window. It (still) defaults to "input 
format=output format", but you can also select jpg, 8bit tiff, 16bit tiff, 32bit 



tiff, 8bit png and 16bit png as output format. This is than valid for the total 
set. 
* Added a "barberpole"  when Imagefuser (enfuse) recalculates the preview. 
* Removed "DEFLATE"  as TIFF compression option. OSX can't handle 
deflated tiffs properly (that is: my Tiger and Leopard versions can't).
* Added FocalLengthIn35mmFormat and FocalLength to Exiftool save options 
for enfused image. With these exif info added, Hugin (and others?) can 
determine focallength and subsequently calculate HFOV from images.
* ExifTool upgraded to version 7.73.
* Added links in Help menu to online manual (forgot that one in 0.5.7) and 
wiki.panotools.org documentation.

0.5.7 13 January 2009
* Added text fields below enfuse sliders. The sliders and the text fields are 
coupled. Sliders are fine for big steps. Text fields help you fine-tune the final 
steps.
* Added a manual
* Changed "About" popup window.
* Added "Save enfused image" and "Save HDR image" to file menu. 
Removed "Create HDR"  from Options menu. Changed "Create .." buttons to 
"Save .." buttons (all to follow Mac OS standards).

0.5.6 10 January 2009
* Implemented a "Image Info" button. This button is available in the main 
screen and in the "Simple Batch" panel.  The button is only enabled after 
images have been loaded and an image is selected. Once it's clicked a panel 
will open showing all available info of the selected image. The panel contains 
a "copy to clipboard" button to enable copying this info.
* Expanded "New Version" popup function. It will now show "whats new" 
information about the new version.
* Fixed a bug with regard to switching from one source format to another 
destination format. This didn't work
  anymore.
* Fixed a bug with regard to colorspace, icc profile and XMF information. I 
mentioned that as fixed in 0.5.2 but it wasn't.

0.5.5 02 January 2009
* Implemented a more flexible way to give names to your "batch fused" or 
"batch HDR"  images. 
Options are:

- <prefix><separated by><autonumber>
- <first image name><separated by><last image name>



- <prefix><separated by><first image name><separated by><last image 
name>
<prefix> is a name that can be freely chosen. <separated by> is - (hyphen), _ 
(underscore), . (point) or nothing.
(And I'm open for useful extensions to this naming options)

0.5.4 24 December 2008
* Implemented an automatic "Check for updates" function. From now on you 
will get a popup when a new version is available.

0.5.3 23 December 2008
* ImageFuser can now also create HDR images (button "Create HDR" and 
menu: Options -> Create HDR). This option is also available from the batch 
mode.
* Changed button "Add bracketed set" to "Open bracketed set" as it gave 
confusion. You can't add addtional sets. You open a set to work with.
* Added more tooltips (help). they are now on almost any text, slider or 
button. If you hover your mouse over it you will see it. 

Done in 0.5.2:
- Color space/RGB correction. Align_Image_stack does not copy the color 
space/RGB info from the source files. In a few situations this can lead to 
unnatural, incorrect colors. 

0.5.2 20 December 2008
* Implemented Phil Harvey's excellent ExifTool (v7.57)  (http://
www.sno.phy.queensu.ca/~phil/exiftool/) into imageFuser. Align_Image_stack 
doesn't copy exif, iptc, jfif and tiff info. Enfuse does this only marginally. 
ImageFuser (actually ExifTool) now copies all relevant info (according to me) 
from the first image of the bracketed set into the final image. This includes: 
ImageDescription, Make, Model, Artist, WhitePoint, Copyright, GPS:all, 
DateTimeOriginal, CreateDate, UserComment, ColorSpace, OwnerName, 
SerialNumber, all IPTC, all JFIF, XResolution, YResolution, ResolutionUnit, 
Lens. 
Note: Align_Image_stack does not copy the color space/RGB info from the 
source files. In a few situations this can lead to unnatural, incorrect colors. 
This has now been fixed by using ExifTool.

0.5.1 17 December 2008
* "Simple Batch"  functionality expanded with the ability to add multiple 
folders. This will not recursively add sub folders, but gives you the ability to 
add additional folders, be it sub folders or folders on other locations.



0.5.0.1 15 December 2008
* Minor bugfix. Application didn't check for correct total number of images (17 
(images) / 3 (images in set) -> Not correct)

0.5.0 14 December 2008
* New enfuse 3.2 CVS version. Contains a couple of bug fixes by Christoph 
Spiel. This includes the bugfix for writing 16bit tiffs (and 32bit tiffs).
* Default image output at startup is .JPG. After adding a bracketed image set 
the output format is automatically set to the input format (jpg input => jpg 
output; 16bit tiff input => 16bit tiff output). This can be changed off course.
* Added a "Simple Batch" functionality. You add a folder containing images 
and you can have ImageFuser align and enfuse your total set of bracketed 
images (and yes: calling this "Simple Batch" means that I'm also aiming to 
implement an "advanced batch" functionality). The "Simple Batch" 
functionality can be started from the menu "Options" -> "Simple Batch". Also 
here: input format is output format. (ToDo: Add more (sub)folders to batch). 
* Fixed a dutch message and translated it to english.
* Added an "Align only" option (menu: Options -> Align Only). Some users 
wanted to only align their images and then feed these into photoshop, gimp, 
ptfsgui, Hugin and so on (enfuse is better, but OK, it's a simple change).

0.4.2 20 October 2008 
* Big code clean up 
* Added "Add bracketed set" button below image table. This button allows 
you to select a bracketed set via a file dialog. With a cluttered desktop it can 
sometimes be handy to add files via a file dialog instead of dragging them 
onto the image table. 
* The File -> Open gives you now also the possibility to select a bracketed 
set. 
* If the window is closed, the application is now closed. 
* Removed the "Auto Level" option. The "auto" blending level was set to 20. 
I've been testing with numerous sets of images and it should definitely be 
somewhere between 25 and 29 for the best results and it is now by default 
set to 27. 

0.4.1 11 October 2008 
* Enfuse has a bug that it can't convert 16bit tiff input images to (8bit) jpeg 
images (when the user requests a jpeg output image). In this case 
ImageFuser will make enfuse write an intermediate 16bit tiff file and than 
convert this 16bit tiff image to 8bit jpeg. The intermediate 
tiff is then removed. 
* ImageFuser > 0.3.2 did not check on existing files causing a "silent" 



overwrite of existing images. This has been corrected. 
* Changed "indeterminate" progress bar ("barber pole") to increasing progress 
bar for align_image_stack steps as these step (can) take very long and a 
step wise progress indicator gives more info. 
* reinstated help buttons for enfuse and align_image_stack tab. 
* "Align Preview" button could be checked without images loaded. It could be 
unchecked with images already aligned. It wasn't unchecked when new 
images were loaded. 
* Expanded tiff output options from only LZW and DEFLATE to PACKBITS, 
NONE, LZW and DEFLATE. 
(* Updated http://wiki.panotools.org pages for enfuse and align_image_stack.) 
0.4.0.2 05 October 2008 
* Due to whatever reason the align_image_stack version bundled with 
ImageFuser version 0.4.0.0 and 0.4.0.1 got partially corrupt. 

0.4.0.1 05 October 2008 
* Minor bugfixes 

0.4.0 04 October 2008 
* Added thumbnail view for source images 
* added basic error checking on text fields. 

0.3.2 02 October 2008 (Not released) 
* ImageFuser now runs on Tiger too.  (Installed my "old" Tiger on an external disk 
and rebuilt the entire project on Xcode 2.5 / Tiger.) 
* Increased size of preview window. 
* Implemented all align_image_stack options. 
(* backward for 0.2.5: upgraded enblend to 3.2) 

0.3.1 26 September 2008
* Fixed bug w.r.t. to input TIF(F)'s. Forgot to remove a test line of code.
* Added a "Log Align_Image_Stack to console". AIS can take a long time to run 
especially on big TIF(F) files. This console output gives you feedback on the 
progress.

0.3.0.1 22 September 2008
* Minor changes to build project. Built on 10.5 (Leopard) but forced as much as 
possible to "delployment target" 10.4 (Tiger). Hopefully not a bug in Applescript 
and/or XCode.

0.3 21 September 2008
* Some code optimalization in loading images
* Change behaviour of progress window.
* Added option to align preview too.



0.2.5Not published. 
* All slider settings and checkboxes work. 
* Correct decimal notation differences "around the world".

0.2 Not published.   
* Preview function Implemented.

0.1 Not published. 
* Straight-forward working of enfuse and align_image_stack.
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